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Overview:

Icon Hacker is a tool for creating new Icons and attaching them to files on the desktop.  Some of the features of
the tool are:

o  Provides several powerful editing modes to allow the user
   to create customized Icons and ICN#'s. Using the IH's set of
   "Logical Operations" it is very easy to create ICN#'s whose
   selected state looks TOTALLY different from its unselected
   state. (The Icon Hacker's ICN# on the desktop is an example
  of this.)

o Automatically creates BNDL, FREF , and "named"resources for 
   application programs, or replaces existing ones. This allows the user    to add custom  ICN#'s to the 

desktop for programs that have none. 

o Icon Hacker will automatically remove BNDL ,FREF and "named"
   from the desktop for files with existing BNDL's. This allows the
   user to customize an ICN# on a file that already has one.

o Allows editing of two files simultaneously, and cutting and pasting
  of Icons or ICN#'s between the two files.

o Icon Hacker is provided with all of the functionality of the
   "File Hacker" product released in November 1986. Consequently,
   the user can modify any file's finder attributes from within
   the tool.

o Icon Hacker Version 1.0 allows users to Rotate or "Mirror" Icon
   images. Rotation takes place in multiples of 90 degrees. The image
   may be flipped about the X or Y axis.

o Icon Hacker Version 1.0 supports bit shifts. Icon Images may be
   shifted left, right, up, or down, any number of pixels. The user
   may decide to shift in either black or white bits, or select a 
   "barrel" shift mode.

o Icon Hacker Version 1.0 supports the extraction of Icon images from
   MacPaint formated Files.

Icon Hacker is shareware. That means it is not free.  Icon Hacker is provided to you on a trial basis for a period 
of 14 days from the time you receive it.. During this period, license is extended to the user for the purposes of 
evaluation. After the 14 days have elapsed, you must send $10.00 to:

Joe Mastroianni
Killer Owl Productions
43 Woodbrook Dr.
Edison N.J. 08820

to be granted a CPU license for continued use on your machine. You may distribute Icon Hacker to other users as you 
see fit. The transfer of these
program materials constitutes a transfer of the same 14 day trial period license.  

For $20.00, a special, "For Registered Users Only..."  version will be mailed to you.
Icon Hacker is written in the Lightspeed flavor of Macintosh C. Naturally, the glue routines are copyrighted by 

THINK technologies. (Glad thats out of the way.)
 Icon Hacker was written and tested on a Macintosh Plus.   Even though I feel most of the bugs have been 

wrung out, my experience in software development has taught me that no code is ever TOTALLY bug free. If you 



happen to find a bug,please bring it to my attention. I can be reached by mail at the above address, or electronically 
through GENIE at  "JOE-M",  or Arpanet/CSnet at  
"jdm%smvl%rca.com@CSNET-RELAY.ARPA". 

The Icon Hacker source code,  the application program, and this manual are all copyrighted materials owned by
Joseph D. Mastroianni.  The author of said materials assumes no responsibility for any loss of data that occurs through 
usage or misuse of the program. 

Now , let's get down to business.

  Getting Started:

o Icon Background

Ok, lets start by examing what we know about the Macintosh Desktop. We know that there are two kinds of file 
on the desktop: application programs, and data files. Application programs (like MacPaint) create the data files. The 
data files could be paintings, drawings, text, or anything an application program needs to store on disk. 

Usually, an application program will have a distinctive icon. Programs  like Lightspeed C and Microsoft Filght 
Simulator have custom Icons. MacPaint and MacWrite have what is known as "default" icons.  A default Icon is what a 
program winds up with if a custom Icon hasn't been "attached" in the right way. We're all used to seeing the default 
application icon. Its a diamond with a hand holding a pen.

Data files created by certain applications sometime have distinctive icons too. MacPaint drawings, when saved 
on disk get an icon that looks like a page of paper with a paint brush  and a brush stroke. Other data files get the 
"default" data file icon, which looks like a blank, dog-eared piece of paper.

What dictates the type of icon you get is something called a bundle. As it turns out, if an application has the 
correct "bundle" or "BNDL" resource, along with the correct "FREF" and "named" resources, then the icons in the 
application program itself will be displayed. Otherwise, the finder uses its boring default icon.

With data files the story is a little different. A data file gets a distinctive icon if the application program  that 
created it had its BNDL's and FREF's set up right. Strange, but true. A data file dosent have icons in it (usually). So, its 
the job of the program that creates it to give it a custom icon. This makes it hard to change the icon on a single data 
file of a given type. Usually, you have to change the icons on all data files of a given type at once. (Of course, you can 
change the default icons. They're in the finder file itself.)

Oh, a word about "ICONs" and "ICN#s".  "ICN#s" are called "icon lists". A single "ICN#" consists of two icons 
(32 by 32 bit pictures), called the "icon" and the "mask". The "icon" part of an "ICN#" is what you see on the desktop 
when the file is unselected. When you select the file, the finder XOR's the mask and the icon
and displays the result.. XOR means that the finder puts the  mask directly on top of the icon. Everywhere the icon and
the mask are BOTH black, the finder turns the area WHITE. Everywhere the icon and the mask are BOTH white, the 
finder leaves white. Finally,  the finder turns BLACK everywhere the icon and mask are different. 

The mask is also used to identify everywhere an icon obscures its background. If the icon and the mask were 
both white, you'd be able to see through the icon if you put it on top of something. Everywhere the mask is black is 
made opaque on the icon. So, most masks are mearly the "shadow" of the icon itself. I mean, if the icon is a dog-eared
piece of paper, the mask is usually made a solid, black, dog-eared paper shape. Then, if you place the icon on top of 
something, you cant see through it. If the mask were totally white, the icon would be transparent !(The selected icon 
would also look the same as the unselected icon.)

"Icons" as opposed to ICN#'s, are a single 32 by 32 bit (pixel) pictures. They are not displayed on the desktop. 
The program uses them for various reasons. (Icon Hacker uses an  "Owl" icon in it's "About Icon Hacker..." menu
item.

Each of the 1024 bits in an icon is called a pixel. Each pixel can be either black or white. (On color computers, a
pixel can represent a  color.) When "Logical Operations" are performed on an Icon or ICN#, the operations change the 
color of the pixels. For instance, if you "Invert" the Icon, every white pixel is turned black and visa versa. "Clearing"  an
Icon turns all of its pixels white. 

Other operations require two icons. The OR operation places one 32 by 32 pixel image on top of the other one. 
The resultant picture has black pixels everywhere EITHER of the two original picutres had black pixels. Where both had
white pixels, the result has white pixels.

As explained above the XOR operation places on icon onto the other. The resultant 32 by 32 bit image has 
white pixels anywhere the originals BOTH had BLACK or WHITE.  If the pixels are different in the two originals, the 
resultant will have BLACK. 

There are other types of Logical Operations (AND, NAND, NOR), but they can all be generated by using 
combinations of Invert, Or, and XOR. Also, Invert, OR, and XOR are all you really need to create nifty icons.

o Design Scenario 1- Changing an Icon

Ok, now that you have heard about BNDL's, FREF's, logical operators, default icons, and whatnot,  lets' go 



through a typical icon design scenario. But first, a caution. Icon Hacker will let you create and delete files as well as 
icons. It will also let you change the icon related resources within a file and a disk's "DeskTop" file. Be sure of what you
are doing before you take an action. Always work on a copy of a file on a scratch disk.  Never edit an original file! 
Never edit a file on  a disk with information on it you cant stand to lose unless you've tried editing first 
on a scratch disk! 

Now, say you want to change the ICN# used by Microsoft word to look the same as the Icon Hacker's ICN# 
when unselected, and like the "selected" version of the Microsoft Word Icon when selected.  You would take the 
following steps.

o Start Icon hacker, and select OPEN from the file menu. Open    Microsoft Word in the usual 
Macintosh manner. A display window   will appear.

o Select ICN# from the EDIT window. All of the ICN#'s within MSWord
   will appear.

o Double Click on the ICN# that is displayed when you see MSWord
   on the desktop. An edit window will pop up. At this point you can
   change the ICN# manually by clicking the mouse in the icon or
   mask grid. We wont need to do that, though.

o Select Open from the file menu, and open a copy of Icon Hacker.
   (You will have had to have created a copy of IH first. Icon Hacker
   will never  edit itself.) 

o Copy the icon to the mask by doing this: Select Logical Operations    from the Pixel Operations 
menu. Select ICN#- Icon as the source.

   Select ICN#-Mask as the destination. Select Copy->Source. Click on
   change. MSWord's mask will be obliterated, and a copy of
   its icon will take its place. The ICN# will now look like two identical
   icons.

o Select ICN# from the  edit menu. The ICN#'s in Icon Hacker will be
   displayed.

o Select "Logical Operations..." from the Pixel Operations menu. A   dialog will pop up. Select Icon 
Hacker as the source file by clicking

  the radio button beside the file name at the top of the display. In
  the "Resource number" entry window, enter the number of the ICN#
  in the Icon Hacker file of IH's desktop ICN#. Select ICN#-Icon as the   source pattern by clicking the 

radio button. Select ICN#-Icon in as   the destination pattern by clicking the radio button. 
  Select "Copy->Source". Click on Change. You should now see a copy
  of MSWord's icon in the "mask" slot, and a copy of Icon Hacker's
  icon in the "icon" slot.

o Select Logical Operations... again. Select ICN#-Icon as the source.
   Select ICN#-Mask as the destination. Select   Invert->XOR. Click on
   change.  The mask will now look like a munged up mess. But, if you
   examine the three icon windows at the bottom of the edit window,    you will see that the middle 

window looks coherent.  This is what    the icon will look like when selected.

o Select Save from the edit window. When asked, select MSWord
   as the file to save to.

o Select "Replace Icon on Desktop" from the BFBuilder menu.

o Exit the program by selecting Quit from the FILE menu.

 When you return to the finder, you will see the MSWord Icon has changed to the Icon Hacker Icon. But, when 
you click on MSWord, you will
see that its icon changes into the selected MSWord Icon.

o Design Scenario 2 - Getting a custom icon displayed for an
       application with no icons.

o Open the application program by selecting Open from the file menu.



o Select ICN# from the EDIT menu.

o If you need to create an ICN# for the application, select New
   from the File menu, and select ICN# when asked what kind of
   icon you're creating.  Create the ICN# through copying from other    files., logical operations, or 

manual "square clicking".

o Select Get Info from the File Menu. Set the ID number of the ICN#
   to something reasonable (>256). Clik save.

o When the ICN# is finished, save it to the application file.

o Select "Build Bundle/Fref" from the BFBuilder menu. When the
   dialog pops up do the following:

-  Enter a four character "name" in the top window. 
   This can be arbitrary, but you need to be sure that
   no other file on your desktop has this same name. You
   can check the other files by looking at their "CREATOR" flags
  with the Hack File Utility explained elsewhere in this manual.

- Leave APPL showing in the second window.  

- Put the number of the ICN# you just created in the third
  window.

- If you're going to bundle icons to files created by your
   your program, put that file type and ICN# in the next
  two boxes. If you dont know what I just said, leave the
  other two entries showing "????" and 0 respectively.

- Select create.

o Exit the program by selecting Quit from the File menu.

The custom icon will appear on the desktop. Be aware that any files created by the program will get the usual 
default icon.

o Running through the menu selections:

 o Apple:

In the Apple menu, selecting "About Icon Hacker..." will display the usual start-up dialog and copyright notice.

 o File:

In the File menu, the selections are context dependent. That means, what happens when you select an Item 
depends on what you are doing at the time.

Selecting NEW when there are no open files will allow you to create a new resource file to store your Icons and 
ICN#'s. If NEW is selected when a file is open, it will allow you to create new Icons and ICN#'s by opening a blank Icon 
or ICN# editing window.

Open opens new resource files. If you try to open a data file that has no resources, it will ask you if you want to 
create a resource fork. Dont do this unless you are absolutely sure the program that uses that file dosen't care if a 
resource fork is there or not. Especially don't do this if you don't know what a "resource fork" is!  A maximum of two 
resource files can be opened at once.

Close closes the front most window. If it is an Edit window, Icon Hacker will ask you if you would like to save 
any changes before closing the window. Clicking the go away box on the Edit window has this same effect.
If the frontmost window is a file display window, the file will be closed.

Save saves the Icon or ICN# in the  Edit window to either of the two open resource files.
Get Info allows you to change the resource ID or name of the Icon or ICN#. Clicking "Save" in the Get Info 

window  DOES NOT CHANGE THE ICON IN THE RESOURCE FILE! It only registers the change in Icon Hackers  edit 



buffer.
To save the change to the resource file, you must select "Save" from the File Menu.

Delete will allow you to delete ANY file on a disk (except for Icon Hacker!) if no files are open. If a file is open, 
and an Edit Window is present, selecting delete will allow you to delete the ICN# from its source file.

Quit checks to see if you need to save any editing, closes all open files, releases any allocated memory, and 
exits the program.

o Edit:

Undo, Cut, Copy, Paste, and Clear are provided in the Edit menu for the use of DeskAccessories, but are not 
used by Icon Hacker.

Hack File Attributes allows you to edit the Finder File Attributes for any file.
Selecting "Icon" will display all of the Icons in the active display window if one is active. If an Edit window is 

active, it does nothing.  When a file is opened, its window initially displays NOTHING.  You must select "Icon" or "ICN#"
to see the resources within the file.

Selecting "ICN#" will  cause all of the ICN#'s within the file assigned to the active display window to be shown.

o Pixel Operations:

These operations are only activated if an Edit Window is present.

Pen XOR and Pen Constant effect the manual drawing mode in the Edit Window. These two selections are 
toggled. 

Pen XOR has the following effect on the pixels in an Edit Window. If you press and hold the button while the 
cursor is in an Edit window, and then move thc cursor, all of the pixels that fall under the cursor will be reversed.

Pen Constant does the following. If the button is  pressed while the cursor is first  in a black pixel, all of the 
pixels that fall under the cursor while the button is held will be turned white.  If the first pixel selected is white, and the
cursor is subsequently moved while the button is held down,
all of the pixels that fall under the cursor will be turned black.

Selecting Logical Operations will bring up a dialog that will allow you to change Icons, or ICN#s by copying 
other icon patterns onto the edit window and performing the appropriate operation (XOR, OR, or COPY). You can also 
clear an Icon or ICN#, or invert its pattern.

o Version 1.0 Enhancements to Icon Hacker

Selecting "Shift..." will bring up a dialog that will allow you to shift the
bit image of either an Icon or Mask image any number of bits from
1->31. Bits may be shifted up,down,left,or right. The bits to be shifted in can be selected by toggling the switches at 
the right of the dialog. Shift in Black, shift in white, or a barrel shift mode may be selected.

Selecting "Rotate..." will bring up a dialog that will allow you to rotate an Icon or Mask Bit image in increments 
of 90 degrees. The rotations are clockwise. In addition, you may flip the image about either the x or y axis. This has 
the effect of mirroring the image.

Selecting "Get Image from Paint File..." will allow you to open a Mac Paint file. The image in the paint file will be
displayed in the dialog. The user can then draw a box in the dialog with the mouse. The piece of the Paint image that 
appears in the user defined box will then be cut to either the Mask or Icon image being edited.

o BFBuilder:

Selecting "Build Bundle/FREF" will allow you to create  bundle, fref, and associated named resources 
automatically and add them to files. If the file already has its own bundle, it can be replaced with a new one by using 
this command. The files "creator" type is automatically set to be the same as the "named" resource. The files "bundle 
bit" is set, and its "Inited Bit" is reset. A file must be open for this operation to be activated.

Replace Icon on Desktop deletes all of the bundles, frefs, and named resources from a disks DeskTop file. The 
Desktop file on the volume from which the file was opened is affected. Naturally, you need to have a file open to use 
this command. The files "Inited Bit" is reset.

o Window/Dialog Description:

o Display Windows:



When a file is Opened with the Open command, a blank window is popped up. To see the icons in the file, you 
must select "Icon" from the Edit menu. Likewise must you select ICN# from the Edit menu to see the ICN#s in a file. 
You may consequently display Icons in one file and ICN#s in another.
At this time, you can not display both the icons and ICN#s in a file simultaneously. You can easily switch between 
displays by selecting Icons or ICN# when the display window is active.

To edit one of the Icons in a file, you simply double click on one of them in the display window. To edit an ICN#, 
you double click on either the icon or the mask. The resource ID number of each Icon is displayed below it.
The resource number of an ICN# is displayed below both the icon and the mask. In this way you can identify which 
icons go with which masks (if its not obvious) in the display window.

If you delete an Icon or ICN# from a file and it dosent immedialely 
disappear from the display window, have no fear. Scroll the window back till you cant see any icons or ICN#s and then 
back again and the resource will have gone. 

o Edit Windows:

Editing takes place via a buffering scheme. The resource, and all of its attributes are pulled into an "edit buffer"
when first selected. No changes of any kind are saved to disk until the Save command is executed FROM THE MENU!  
The resources ID or name may be changed in the edit buffer through use of the Get Info command. These changes are
not saved to disk untill save is selected from the File Menu.

The Icon Edit window consists of a 32 by 32  grid of boxes that represent individual pixels.. You may click in the 
grid to change the pixels. You may set the pen mode by using the Pen XOR or Pen Constant switches in the Pixel 
Operations window. The icon is displayed in its normal size under the grid.

The ICN# edit window consists of two 32 by 32 grids. Pixels in the icon or mask may be changed by clicking in 
a grid. The pixels depicted by the icon editing grid is displayed in normal size under that grid. Similarly, the mask 
pixels are displayed under the mask editing grid. Below the space between the two grids is a depiction of the what the
ICN# will look like when selected. This is simply the XOR of the icon and mask. So you can see what the icon will look 
like in an open finder window by looking at the rightmost image. The center image shows what the selected ICN# 
looks like. The leftmost image is never seen when in the finder.

o Dialogs:

o Save to Which File?

Click the arrow pointing to the file name you want to save your editing to.

o File Dosent Have A Resource Fork...?

Clicking "Create" creates an empty resource fork in a file with no resource fork at all. You need to have a 
resource fork in your file to be able to save icons and ICN#'s to it. However, you shouldnt arbitrarily create resource 
forks in data files.  Open a new file if you arent sure what to do.

o Delete File Named ...?

This is a confirmation dialog to give you one last chance to cancel a command to delete a file.  Select the file 
with the "Open" command in the standard file dialog. Then, click DELETE in this dialog to delete the file.  Cancel does 
just that.

o What Kind of Resource ...?

After selecting New from the File Menu, click ICON or ICN# in this dialog to create the appropriate resource 
in Icon Hacker's edit buffer.

o Save Changes To....?

If you make ANY kind of change to an Icon or ICN#, and attempt to close the Edit Window or edit the program, 
this dialog will appear to give you one last chance to save your editing to disk. Click "Save" to write the editing to disk,
"Cancel" to cancel the close operation altogether,  or "Discard" to close the edit window without saving.

o Delete Icon (or ICN#)....?



This is a confirmation dialog to give you one last chance to cancel a command to delete an Icon or ICN# from a
disk file.

o The Get Info Dialog.

The current resource ID and name are displayed for the Icon or ICN#. Either of these can be changed. Click 
"Save" to store the new resource  ID and name to THE EDIT BUFFER.  These changes are NOT saved to disk until the 
"Save" command is issued from the File Menu.

o File "..." Has Bundle/Fref resources. Replace Them?

Clicking "Create" in this dialog deletes all the BNDL, FREF, and "named" resources in a file, and adds 
Bundles,Frefs, and "names" resources as determined by entries made in the Bundle/Fref Build dialog.

o The Bundle/Fref Build Dialog:

Replace the "????" with the four character "named" resource name.  This name will also become the files 
"Creator" type. Be careful not to duplicate the creator type of any file already on the desktop. You can check the 
creator name (and MANY other interesting things) of a file by using the
Hack File Attributes command.

Next, you will see two groups of two entries. At the current time, Icon Hacker can only create bundles with two 
ICN#s specified. Be careful not to replace a bundle in a file that specifies more than TWO FILE->ICN# relationships.

Lemme explain. Each group of two entries has a space for a four character "File Type", and a corresponding 
ICN# number. The first file type is defaulted to APPL, cause most BNDL's are tied somehow to application programs.  
Lets say you want ICN# 300 from the programs file to be used by the Finder on the desktop. Enter "300" in the ICN# 
slot.  What this bundle means is this:

- Tell the finder that when it sees a file with my creator name, give    display ICN# number 300 if 
the file type is "APPL". (APPL means    application program, to the Finder). 

Now, lets say that your program creates files. Say the file type of the files created by your program is "ABCD". 
Now, you want this specific ICN#, number 301 in the program, to appear on the desktop whenever one of these 
"ABCD" files is created. In the SECOND set of two entries in the Bundle/Fref builder you put "ABCD" for the file type, 
and 301 for the ICN# to be attached to that file.  The meaning of the TOTAL bundle is this: (lets assume we've set our 
named resource type to JOEY.

- Hey, Finder, if you see a file whose creator is JOEY, and whose type is   APPL (its an application program), 
display ICN# 300 out of the   application's resource fork instead of the default icon.

  Hey, Finder, another thing!  If you see a file whose file type is "ABCD"   that was created by a program whose 
creator type is "JOEY", display

  ICN# 301 out of that application program instead of the default icon.

Thats pretty much all you need to know. There are other types of resources involved called FREFs, and 
"named" resources that are needed to make the finder display the right ICN#, but Icon Hacker will create all of those 
for you, so you dont need to be concerned about what they do. (If you're really interested, read Inside Macintosh Vol 
III,  or MacTutor.)

o The Logical Operations Dialog:

Logical operations all do something to an entire 32 by 32 pixel image.
(As opposed to the pixel by pixel mouse editing technique). There are two types of Logical Operations: those that 
involve two images (dyadic), and those that only involve one image (monadic).

Dyadic operations provided by Icon Hacker are :
- Invert->XOR
- Copy->Source
- Copy->OR
- Copy->XOR

Monadic operations are:



- Clear
- Invert.

Dyadic operations require you to specify both a source and destination image. Monadic operations only require 
you to specify a destination. 

First, let me explain the monadic operators. "Invert" simply takes every black pixel of the destination 
image and turns it white. It simultaneously takes each white pixel of the destination and turns it black.
"Clear" simply turns all of the pixels in the destination white.

The dyadic operators are somewhat different (and much more interesting).
Copy->Source copies the entire source image into the destination image. The original destination image is 

obliterated, and the source takes its place.
Copy->XOR lays the source image onto the destination and performs an XOR on each pixel to give you the 

result. (For those that dont remember,
XOR is ---- black+black = white, white+white=white, black+white=black.)

Copy->OR lays the source image onto the destination and performs an OR operation on each pixel to give the 
result. OR is --- black+black=black,
white+black = black, white+white=white.

Invert->XOR lays an INVERTED copy of the source image onto the destination image and performs an XOR. This
is the same as saying:
white+black = white,black+black = black,white+white = black.

When specifying the source image for a dyadic operation, you can choose from three places; either of two open
files, or the edit window itself.
When dealing with an Icon as a source or destination, there is no issue as to what gets operated on. An Icon, as 
opposed to an ICN#, only has ONE image.

ICN#'s complicate matters, just a little. Each ICN# has TWO images, an icon and a mask. If you are 
specifying an ICN# as the source or destination for an operation you need to specify one of three cases:

- Operate on the icon half of the ICN#
- Operate on the mask half of the ICN#
- Operate on BOTH halfs.

If you are dealing with an ICN#, you may want to perform some operation involving the icon and mask (like 
Copy->XOR icon to mask). In this case,
leave the source files buttons alone, leave the resource number 0, and just use the radio buttons for source and 
destination. To Copy->XOR the icon to the mask  click ICN#-Icon as the source, ICN#-Mask as the destination, 
Copy->XOR as the operation. Click "CHange" to perform the function.

If you want to bring an image in from an external file, do the following. Select the file by clicking the 
appropriate radio button (the file MUST be opened). Type in the resource  number of the resource to be used as the 
source.  Click "Icon" if its an Icon. Click ICN#-Icon if you wish to use the icon part of an ICN# as the source,  ICN#-
mask if you wish to use the mask part,  and Entire ICN# if you wish to use both the Icon and the Mask.
(Selecting "Entire ICN# naturally obviates the need for you to select a destination. Note that you cannot select this if 
the destination is an Icon resource.) Select a destination  and an operation in the manner described above, and click 
"Change" to perform the operation.

Remember that performing these operations only changes the images in Icon Hacker's edit buffer. You will need
to select Save from the File menu to save your editing to disk.

o The File Hacker Dialog:

This dialog allows you to display and modify a file's finder attributes. You don't have to change any of these 
attributes manually when adding or switching icons, so there isnt any need for you to use this utility for anything but 
display under normal circumstances. However, the experienced Macintosh user or any Macintosh developer usually 
needs to edit these parameters at one time or another. 

The dialog pops up displaying all of a files current attributes. You can change any of these by clicking the check
boxes or entering new file types or creators in the edit boxes. Directory attributes are displayed but cannot be 
changed.

Clicking "Save" saves your changes to disk and brings you back to the main menu. Clicking "Cancel" brings you



back to the main menu without saving.  "Save+" saves your current editing to disk, and immediately brings you back 
to the file selection dialog.This is the same as clicking "Save" and them immediately selecting "Hack File Attributes..." 
from the Edit Menu. (This is a small convienience left over from the File Hacker application.)  Cancel+ , likewise 
bypasses the main menu and brings you immediately to the file selection dialog to edit another file. This is the same 
as clicking "Cancel", and then immediately selecting "Hack File Attributes..." from the EDIT menu.

o The Shift... Dialog (Version 1.0 Only)

Select either the up,down, left, or right radio button to select the direction of the shift. In the center edit text 
window, put in the number of bits to be shifted.  In the rightmost set of three buttons, select either the white box, the 
black box, or the barrel button. If black is selected, the bits shifted in will be black. So, if you shift right 1 bit, a column 
of black bits will be shifted in to the leftmost side of the selected image. Similarly, if the white box is selected, a 
column of white pixels will be shifted in. If "Barrel" is selected, the bits that are shifted off the image on the right side, 
will appear on the left side. A barrel shift makes the image appear like a rotating cylinder. ANything that gets shifted 
off the end of the image, appears on the other side. So, for instance, if you shift upward 10 bits, and barrel shift is 
selected, the image will move upward 10 bits, and the 10 bits that were shifted off of the top of the image, will appear 
as the bottom 10 bits.

o The Rotate...  Dialog

To rotate ether an Icon or Mask image by 90,180,or 270 degrees clockwise, select the appropriate radio button.
If FlipX is selected, the image is mirrored about the X (horizontal) axis. That is,the topmost row of bits will become the 
bottom most row. The next to the top, will become the nect to the bottom row, and so on. Selecting FLIPY will perform 
the same operation about the Y (Vertical) axis.

o The Get Image From Paint File... Dialog (Version 1.0 only)

This is a very functional dialog, with a slightly strange operation. First, the user selects the Mac Paint file to 
open using the standard file opening dialog. Then, the "Get Image..." dialog will appear. In the large box in the center 
of the dialog, the Mac Paint image can be seen. This image can be scrolled in the usual manner using the scroll bars 
provided. When the user sees a desirable  piece of the Mac Paint image,  he/she places the mouse in the box, and 
presses and drags.  A box will be formed around the
desired piece of the image. By then selecting "Cut to Icon" or "Cut to Mask" the image in the user selected box will be 
transferred to either the Icon or Mask image being edited.

Icon Hacker will only let a portion of the Mac Paint file be cut at a time.  As the user will see, due to the small 
size of an Icon or Mask image, only a small piece of a Mac Paint image is reasonable to use. If too large an image is 
selected, the resulting Icon or Mask will look NOTHING like what is intended. SO, as a rule, you will find that only small 
pieces of Mac Paint images are useful as Icons. 

o Limitations:

As Dirty Harry (Clint Eastwood) said: "A man's gotta know his limitations." Consequently, here are Icon Hackers 
current limitations.
All of these are imposed arbitrarily by the developer as memory saving measures, and can be easily expanded in 
future versions.

- Currently, Icon Hacker cannot edit a file that contains
   more than 200 Icons or ICN#'s.

- Icon Hacker cannot remove more than 10 FREFs or
   ICN#'s , as specified by a Bundle,from the DeskTop at one                 time. 

- Icon Hacker can only create a Bundle that references
   two FREFs and ICN#'s.


